Posh Portal access via Single Sign On (SSO) is failing

Incident Report for Posh Technologies

Resolved

This incident is resolved. We have confirmed access is working again with multiple clients that were affected by this.
Posted Oct 23, 2025 - 12:22 EDT

Monitoring

We have identified the issue and implemented a fix. We are now monitoring and seeing successful logins.
Posted Oct 23, 2025 - 11:45 EDT

Investigating

We are currently investigating an issue with access to the Posh Portal for clients using SSO.
Posted Oct 23, 2025 - 11:24 EDT
This incident affected: Knowledge Assistants and Posh Portal.