Posh Portal Impaired
Incident Report for Posh Technologies
Resolved
We have resolved the issue.
Posted Apr 30, 2024 - 14:09 EDT
Investigating
We are currently investigating issues with the Posh Portal including Knowledge Assistant. We will update this incident as we know more.
Posted Apr 30, 2024 - 13:48 EDT
This incident affected: Posh Portal and Knowledge Assistants.